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Preface

Congratulations on your purchase of the ClayTools™ system for Maya® software! This 
document shows some of the different ways that the ClayTools system can be used within 
the Maya pipeline for creating and editing detailed organic models. 

This document assumes the reader is an experienced Maya user. The workflows are 
intended to act as an overview of ways to use the system and do not illustrate each method 
in step-by-step detail.

Resources for Learning About the ClayTools System

ClayTools includes the following documentation.

The ClayTools for Maya Getting Started Guide  An electronic document containing 
instructions on installing and setting-up the ClayTools system. The getting started guide 
also contains information on using the HapticExtender/MY and a brief introduction to 
ClayTools.

The ClayTools for Maya Workflow Guide  An electronic document that shows how the 
ClayTools system and Maya work together. 

The PHANTOM® Omni ™ User’s Guide  A printed document that is shipped with your 
haptic device that describes the process of installing the device drivers and connecting the 
haptic device as well as how to work with the device including proper handling, 
troubleshooting and device specifications. 

The ClayTools online Help   More information on how to use the various tools within the 
ClayTools application can be found in the ClayTools online Help. Help is accessed either 
from within the application or from Start > Programs > ClayTools for Maya > ClayTools 
Help. Context-sensitive quick help is available for each of the tools within the floating 
toolbars.

The ClayTools Quick Reference Card  An electronic document that provides an 
overview of Hotkey Shortcuts and Key Concepts for ClayTools as well as a glance at all 
the ClayTools toolbars and their commands.   

You may also find additional useful learning tools, such as videos and sample models, on 
the product CD.
ClayTools for Maya -  Workflows i



  PREFACE 
Typographical Conventions

This guide uses the following typographical conventions: 

Convention Description Example

Bold Keywords, actual user input, 
or examples.

Click Ok.

italics Indicates a variable; 
reference to another 
document or file.

<Install directory>

Greater Than (>) Indicates a menu pick, as in 
“select Options from the 
Tools menu”; used to 
enclose a variable.

Tools > Options
ii ClayTools for Maya -  Workflows
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Chapter 1 Introduction

ClayTools offers the advantage of unconstrained creative exploration without the need to 
think about the more technical aspects of modeling. A model generated in ClayTools can 
be used as a foundation for building the more technically complete model for the 
downstream production pipeline. Modelers can optimize the polygonal density and flow 
using the ClayTools model as a touchable reference within ClayTools or Maya. In 
addition, the detail from the ClayTools model can be extracted in the end to produce high 
quality normal/bump/displacement maps.

There are a number of workflow approaches within Maya for building the technical model 
using the ClayTools model as a 2D/3D reference. In a way, the model from ClayTools 
serves as a “virtual maquette.” Unlike a real maquette, all of the design intent already 
exists in a digital form. Therefore, the virtual maquette can be leveraged to build the 
technical model for the digital content pipeline. In addition, the HapticExtender/MY plug-
in offers a number of powerful capabilities to assist in building the technical model, such 
as feeling the reference model while editing a low-polygon mesh or even placing spline or 
curve points.

This document contains several workflows that show how a user can either start in Maya 
and then use the ClayTools application to add details (sometimes referred to as working 
from low-resolution to high-resolution) or using ClayTools as a front-end for the Maya 
digital content pipeline by creating high-detailed models in ClayTools and then using a 
variety of techniques to derive a low-resolution model for texture mapping (high-res to 
low-res). 

Both workflows involve using ClayTools to generate a model with a high-level of detail 
which is then baked down to normal maps, bump maps and displacement maps using 
TextureKiln™. 
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1  INTRODUCTION 
• Start with Maya Software
In this workflow, a new or existing low-poly Maya model is imported into ClayTools 
where it is transformed into virtual clay and details are added. Then, the ClayTools 
TextureKiln is used to bake the clay details into texture maps to be applied to the low-
poly model for downstream use.

FIGURE 1-1. Low-Resolution to High-Resolution workflow
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1  INTRODUCTION 
• Start with the ClayTools System
This workflow leverages ClayTools for testing out multiple concepts and rapidly 
creating a high-detail virtual maquette. Then choose from a variety of methods to 
derive a low-poly production model. Lastly, the ClayTools TextureKiln is used to 
bake the clay details into texture maps to be applied to the low-poly model for 
downstream use. 

FIGURE 1-2. High-Resolution to Low-Resolution workflow
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1  INTRODUCTION 
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2

Maya to ClayTools

Chapter 2 Creating A Game Character 
Model with Maya and ClayTools

This workflow goes through the process of working from Maya to ClayTools to create a 
game character model with normal maps. Sample files can be found on the product CD if 
you want to follow along. Note that not every step is explained in detail. This is not 
intended to be a step-by-step tutorial.

The core principle of this workflow is to create high resolution models from tessellated 
game models and generate normal maps from them. In this workflow, we will first export 
a lo-res game model from Maya to ClayTools. Next we will increase the resolution of the 
geometry in ClayTools. Finally we will generate normal maps using TextureKiln and 
apply the normal maps to the original game model in Maya.
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 1: Exporting Objects from Maya and Importing into ClayTools
This workflow is broken into the following parts:

Part 1: Exporting Objects from Maya and Importing into ClayTools

Step 1: Preparing to export the game model from Maya

FIGURE 2-3. Model in Maya

Topic Page

Part 1: Exporting Objects from Maya and Importing into ClayTools 2-2

Part 2: Modeling High-Resolution Model in ClayTools 2-9

Part 3: Generating Normal Maps 2-16

Part 4: Applying the Normal Map and Previewing Normal Map in Maya 2-21

World units must be consistent

Both Maya and ClayTools should be set to consistent world units in order to 
avoid unnecessary rescaling of units. In ClayTools, this option is found under 
Options. In Maya, this setting is found under the main toolbar heading 
Windows > Settings/Preferences > Preferences > Settings. 
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 1: Exporting Objects from Maya and Importing into ClayTools
1 To follow along, in Maya, open bodyStart.ma file, which can be found on the 
product CD. 

Before exporting the polygon geometry to ClayTools, you need to smooth the model using 
the smooth node in Maya. This is important because ClayTools converts geometry to clay 
(voxels), so even though you make the resolution of the geometry high, ClayTools will 
respect the form of the imported geometry and represent it more smoothly. 

2 Select the polygon geometry (bodyGeo) and go to Modeling > Polygons > Smooth 
Options (Figure 2-4). 

3 In the Polygon Smooth Options dialog, set following:
a Subdivision Method to Exponential
b Subdivision Levels to 4
c Continuity to 1
d Make sure Keep Geometry Borders is checked on as without this option, the 

geometry will shrink and it will cause problems during the normal map 
generation process in ClayTools. 

FIGURE 2-4. Maya Polygons Smooth Options dialog

4 After all the options are set, click Apply.
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 1: Exporting Objects from Maya and Importing into ClayTools
The geometry with subdivision level 4, may look overly tessellated, but it is important to 
have a dense poly mesh to get a smooth clay model in ClayTools.

FIGURE 2-5. Geometry shown with various subdivision levels
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 1: Exporting Objects from Maya and Importing into ClayTools
FIGURE 2-6. Clay shown when converted from various subdivision levels
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 1: Exporting Objects from Maya and Importing into ClayTools
Step2: Exporting the tessellated geometry from Maya
ClayTools supports the Wavefront Object format (.obj). An OBJ exported comes with 
Maya but it is not loaded by default.

To load the OBJ exporter, 

1 Go to Window > Settings/Preferences > Plug-in Manager (Figure 2-7).
2 Turn on the loaded check box for objExport.mll and this will load the exporter. 

FIGURE 2-7. Maya Plug-in Manager with obj exporter selected.

3 Select the geometry (bodyGeo) and go to the File > Export Selection Options 
(Figure 2-8). 

4 Change the File Type to OBJexport in the General Options and make sure all the file 
type specific options are turned on.
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 1: Exporting Objects from Maya and Importing into ClayTools
FIGURE 2-8. Maya Export Selections dialog with OBJExport selected and all File Type 
Specific Options on.

5 Click Apply to export. Name the file torso.obj.
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 1: Exporting Objects from Maya and Importing into ClayTools
Step 3: Importing tessellated geometry to ClayTools
In ClayTools, select File > Import > Model and load the OBJ file (torso.obj) that you 
exported from Maya. Before converting polygons to clay, the import model dynabar 
appears in the bottom of ClayTools window (Figure 2-9) giving you options to set for the 
import. 

1 In the Import Model dynabar set the following:
a Set Size to mm,
b Set Import Mode to Fill Holes
c Set Clay Coarseness to Custom
d Set Edge Sharpness to 0.2mm.

FIGURE 2-9. Import Model dynabar

The clay coarseness used in this example is particular to models of this resolution and is 
typically used when importing high resolution models. In most cases, you can start with 
the default “add detail” or “add fine detail” clay coarseness.

2 Click Finish and ClayTools will convert the polygonal model to clay.

Tip In ClayTools, do not reposition or scale the piece as the polygons and 
Clay need to be overlapping to generate normal maps using TextureKiln
2-8 ClayTools for Maya -  Workflows



2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 2: Modeling High-Resolution Model in ClayTools
Part 2: Modeling High-Resolution Model in ClayTools

Step1: Adding definition to the model
The Attract tool in ClayTools is similar to the Maya sculpt polygon tool.

Use the attract tool to add definition to the geometry (Figure 2-10 and Figure 2-11)

FIGURE 2-10. The model shown on top is as imported. The one on the bottom shows the 
beginning of some definition that was created using the attract tool 

Definition is added
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 2: Modeling High-Resolution Model in ClayTools
FIGURE 2-11. Comparison of back of the model before and after definition is added using 
Attract

The basic processes of adding definition are pushing and pulling using the attract tool and 
smoothing by using the smooth tool. 

Tip  Use the Batch Mirror or Interactive Mirror for symmetrical models.
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 2: Modeling High-Resolution Model in ClayTools
Step 2: Adding details on the clay surface
Before adding details to the clay, you need higher resolution clay to get good results. To 
change clay coarseness:

1 Go to Pieces > Clay Properties > Clay Coarseness. Make Edge Sharpness to 0.1, 
smooth on and click OK.

You will begin adding details, starting with the chest armor section. You will create this 
detail by embossing the clay object. The ClayTools emboss tool works with a closed curve 
on the clay.

2 Draw a closed curve on surface using the Draw Curve tool that outlines the shape of 
the bodice. Use Figure 2-12 as a guide. The Draw Curve tool is similar to Maya's 
curve on surface tool.

Tip  Make sure that you are feeling the surface with the Omni device when you 
are placing the edit points. It is also important to enable the “Fit on Create” 
option of the Curve tool in the dynabar.

3 Go to the Emboss tool and then select the closed curve that you just created.
4 Once you select the curve, touch the clay inside the curve loop and pull the clay out.

FIGURE 2-12. A curve is drawn to outline the bodice of the chest armor
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 2: Modeling High-Resolution Model in ClayTools
FIGURE 2-13. Emboss is used to create the bodice 

The Emboss Area tool allows you to use alpha images to define the emboss area on the 
clay surface. ClayTools supports bmp, jpg and psd formats for alpha images.

5 Go to the Emboss Area dynabar (Figure 2-14) and select the Custom Pattern option.
6 Click on the checkerboard image next to the Pattern control to load the custom alpha 

image.
7 Navigate to and open the desired image. The triangleAlpha.bmp is used in this 

example.

FIGURE 2-14. Emboss options in the dynabar with a custom pattern displayed in the 
thumbnail

FIGURE 2-15. A bitmap of the traingleAlpha.bmp is displayed in the dynabar
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 2: Modeling High-Resolution Model in ClayTools
8 Reduce the Diameter setting on the Emboss Area Dynabar until the image is 
approximately the size displayed in Figure 2-17.

9 Stamp the triangle alpha image on the clay. Figure 2-17 shows several embosses as 
well as several stamps in process.

10 Before embossing the area, set the dynabar option to “Raise” clay and set 
the Emboss Distance to 0.25 and click Apply (Figure 2-16).

FIGURE 2-16. Raise option is selected in dynabar and Emboss Distance is set to 0.25

FIGURE 2-17. Upper row of triangles have been embossed. Another row is being stamped.

The Mask tool lets you create a mask on the clay by directly painting on the clay or using 
alpha images. 

Note  When you are in the mask mode, only deformation tools work on the 
masked surface.

11 Click on the Mask tool.
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 2: Modeling High-Resolution Model in ClayTools
12 Set your Mask options on the Mask dynabar
a Select Custom Pattern (Figure 2-18).
b Click on the image next to the Pattern and navigate to desired image, here 

armorAlpha.bmp (Figure 2-19) in the alpha folder in the project directory.
c Set the Falloff to 0%

13 Paint the armor alpha on the clay (Figure 2-20). Note you must be touching the clay to 
apply the mask.

The Red color means that the clay is masked so the deformation will not affect that area. 
However you want the currently painted area to be the unmasked area and the rest to be 
masked. To do this you need to invert the selection.

14 Select Edit > Invert Selection to invert the mask (shortcut is Ctrl+I)
15 Select the Tug tool and pull the clay out.
16 Click Apply on the dynabar to complete the operation.

FIGURE 2-18. The Mask dynabar

FIGURE 2-19. armorAlpha.bmp
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 2: Modeling High-Resolution Model in ClayTools
FIGURE 2-20. The armor image is stamped on the clay.

The other parts of the character can be created using the same workflow. To add more 
finer details on the clay, you need higher resolution clay to get finer details. This is 
managed by changing the Clay Coarseness.
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 3: Generating Normal Maps
Part 3: Generating Normal Maps

Step 1: Creating UVs in Maya
To generate a normal map, you need UVs define on the polygon model (fig 20)

FIGURE 2-21. UVs in Maya

In Maya we open bodyStart.ma, which already has the UVs created on it. For those 
already familiar with UV mapping, skip ahead to “Step 2: Generating the Normal Map” on 
page 19
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 3: Generating Normal Maps
Example: Creating 
UVs

Though the UVs already exist in the sample model, this section of the tutorial goes though 
the process of creating those UVs in Maya.

1 Select the front polygon faces of bodyGeo (Figure 2-22)

FIGURE 2-22. Front polygon faces are selected 

2 Select Edit Polygons > Texture > Planar Mapping
3 Select Window > UV Texture Editor
4 Select the polygon faces in the UV Texture Window then select Polygons > Relax 

UVs option box.
5 In the Relax UVs Option box, Figure 2-23, 

a Set Edge Weights to World Space
b Turn on the Pin UV Border check box
c Set Max Iterations to 5 
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 3: Generating Normal Maps
FIGURE 2-23. Relax UV Options dialog

Apply the same process to the back side of the polygon faces and the arms (Figure 2-24, 
Figure 2-25). As for the arms' UV, use Edit Polygon > Texture > Cylindrical Mapping to 
start the process.

FIGURE 2-24. Back polygon faces are selected
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 3: Generating Normal Maps
6 Export the model to bodyUV.obj.

FIGURE 2-25. Polygon faces on the arms are selected

Step 2: Generating the Normal Map
In ClayTools, open the clay file you created in Part 2. You can generate normal maps in 
ClayTools using TextureKiln.

1 Go to File > Export > TextureKiln.
2 In the TextureKiln Options dialog, set the following (see Figure 2-26): 

a Map types to Normal Map
b Normal Map Options to Tangent Space
c Tangent space options to Maya Hardware settings
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 3: Generating Normal Maps
d Texture resolution to 1024.

FIGURE 2-26. TextureKiln settings

3 Press the OK button. You will be asked to choose a polymesh file with the UVs. 
Select the bodyUV.obj file you created previously. When TextureKiln is done creating 
the normal map you will be asked to save the file.
2-20 ClayTools for Maya -  Workflows



2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 4: Applying the Normal Map and Previewing Normal Map in Maya
Part 4: Applying the Normal Map and Previewing Normal Map in Maya

In order to view the normal map on the model in Maya's viewer, you need to create a 
custom normal map shader. To create the shader, connect the outColor attribute of the 
normal map image file to the shader's normalCamera attribute (see Figure 2-27).

FIGURE 2-27. Node connection of normal map

By using the createNormalMapShader script, you can automate this process.

1 Load the bodyStart.ma file.
2 Go to Window > General Editors > Script Editor.
3 Go to File > Source Script and open createNormalMapShader.mel from the scripts 

folder in the project directory.
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 4: Applying the Normal Map and Previewing Normal Map in Maya
4 Once the script is sourced, type createNormalMapShader and hit enter on the 
numerical keypad. The command will generate the normal map shader.

FIGURE 2-28. New normal map shader shown in HyperShade

5 Display the attribute editor for the normalMapFile node. This can be done in the 
HyperGraph. Select Rendering > Show Textures then right-click on the 
normalMapFile node and select normalMapFile... to display the attribute editor. 

6 In the attribute editor, select the normalMapFile tab. Click on the folder icon next to 
“Image Name”. Select the file you created with TextureKiln.

7 Open HyperShade. Drag and drop the normalMapSN material onto the body.
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 4: Applying the Normal Map and Previewing Normal Map in Maya
8 Go to the Shading menu on the viewer window and turn on High Quality Rendering, 
Smooth Shade All and Hardware Texturing to see the normal map result (Figure 2-
29).

FIGURE 2-29. Torso displayed as wireframe and with smooth shading.
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 4: Applying the Normal Map and Previewing Normal Map in Maya
FIGURE 2-30. Torso display with normal map. 
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 4: Applying the Normal Map and Previewing Normal Map in Maya
FIGURE 2-31. Armor has been detailed using various tools and additional pieces of the model have been created 
using the same workflow.
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2  CREATING A GAME CHARACTER MODEL WITH MAYA AND CLAYTOOLS 
Part 4: Applying the Normal Map and Previewing Normal Map in Maya
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3

Maya to ClayTools

Chapter 3 Adding Detail to a Maya Model

This chapter describes the workflow process of working from Maya to ClayTools to 
develop a low polygon, normal mapped object. 

The core principle of this workflow is the notion of extracting high-detail surface 
information and “baking” it into a map that's applied to low-res geometry. This process is 
called normal mapping.

This workflow is advanced in nature because it demonstrates round-trip modeling of a 
low-resolution model and a high-resolution counterpart. We will start in Maya with a 
model of a low-resolution demon polymesh. We will then export a Poly Smoothed version 
of the demon and import it as virtual clay in ClayTools. ClayTools will be leveraged for 
adding detail to the demon model, such as musculature, veins, bumps, horns, spikes, teeth, 
tongue, and skin details. We'll then export a downsampled version of the demon to be used 
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3  ADDING DETAIL TO A MAYA MODEL 
Part 1: Exporting Maya Models and Importing into ClayTools for Detailing
as a 3D reference in Maya for further refinement of the low-resolution demon model. This 
refined UV mapped model will become the low-resolution target for a normal map and the 
ClayTools model will be the detailed source. The completion of the workflow will show 
using the TextureKiln to bake a normal map from the densely detailed virtual clay, which 
will then be applied in Maya to the low-resolution demon model. 

This workflow is broken into the following parts:

Part 1: Exporting Maya Models and Importing into ClayTools for Detailing

Step 1: Preparing to export the low-res model
We will begin with a low-res polymesh demon model for which we want to create a 
detailed counterpart. 

Topic Page

Part 1: Exporting Maya Models and Importing into ClayTools for Detailing 3-2

Part 2: Detailing the Model in ClayTools 3-9

Part 3: Refine the Model and Assign UV Maps in Maya 3-13

Part 4: Baking ClayTools Detail into Texture Maps Using TextureKiln 3-17

Part 5: Evaluating the Normal Mapped Result in Maya 3-23
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3  ADDING DETAIL TO A MAYA MODEL 
Part 1: Exporting Maya Models and Importing into ClayTools for Detailing
1 Load the 01startInMaya.mb file.

FIGURE 3-1. The low resolution demon model

2 Make a copy of the demon mesh directly on top of the existing demon mesh.

For organic detail modeling, it is recommended to smooth out any faceting that will not be 
desired in the high detail model. The smoothed result will provide a better starting place 
when the mesh is converted to clay in ClayTools. 

3  Perform a Polygons > Smooth operation. Note this may take some time.

A good rule is to increase the number of subdivision levels or number of smooth 
operations until you no longer have discernible facets. Use the facet viewport display to 
judge your iterative step results. From a short distance, the mesh should appear smooth. 
Here we have increased the number of subdivision levels to 3.
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3  ADDING DETAIL TO A MAYA MODEL 
Part 1: Exporting Maya Models and Importing into ClayTools for Detailing
.

FIGURE 3-2. Polygon smoothing applied to model to provide a smooth surface for detailing.

It is recommended to preview the model in flat shading mode within Maya to ensure that 
visible faceting has been eliminated. Upon export the smoothed mesh should be deleted 
from Maya. 

World units must be consistent

Both Maya and ClayTools should be set to consistent world units in order to 
avoid unnecessary rescaling of units. In ClayTools, this option is found under 
Options. In Maya, this setting is found under the main toolbar 
heading.Windows > Settings/Preferences > Preferences > Settings. In this 
particular workflow it is preferable to use centimeters, as this is the native unit 
of measure in Maya. Not adhering to this may cause data to be scaled 
incorrectly due to unit conversion methods used by the OBJ import/export in 
Maya.
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3  ADDING DETAIL TO A MAYA MODEL 
Part 1: Exporting Maya Models and Importing into ClayTools for Detailing
Step 2: Exporting the low-res model from Maya 
After prepping the model, the next step is to export the model as a dense polygonal mesh. 
ClayTools supports Stereo lithography (.stl), both binary and ascii, as well as Wavefront 
Object (.obj). For this workflow we will export as obj.

• In Maya select File > Export or Export Selected and select Wavefront (obj) as the file 
format. Upon export, the OBJ Exporter popup dialog will appear. 

FIGURE 3-3. Export as OBJ format. Note that though the file type specific options are 
turned off in the above image, it is of no consequence in this example.

Step 3: Importing the low-res model to ClayTools.
The next step is to import the model into ClayTools. This can be done using 
File > Import > Model. The following images walk you through the process.
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.

FIGURE 3-4. ClayTools File > Import > Model

What if you lose detail upon import?
If you lose detail when importing a model into ClayTools, you can try 
importing it again at a finer level of clay coarseness. Typically, Add 
Detail or Add Fine Detail levels will be a sufficient starting place when 
detailing a model. The finer the clay coarseness, the more detail you 
will capture at the cost of higher memory usage and lower perfor-
mance. Clay coarseness of a ClayTools model is similar in that way to 
the pixel resolution of a bitmap image. You can set the clay coarseness 
on the Import dynabar during the import file process
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FIGURE 3-5. Import File Info is set in the dynabar.

The Edge Sharpness is set to .01mm. This means that each square millimeter of virtual 
clay is the size of the grid of voxels that are .01mm in size. It is the size of the smallest 
surface feature.

About Voxels
A voxel, an abbreviation of “volume element”, can be thought of as a 
three-dimensional pixel. It is a unit of volume that can be represented 

numerically by its specific position in x, y, and z coordinates.
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FIGURE 3-6. The initial demon model imported into ClayTools and converted to virtual clay.
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Part 2: Detailing the Model in ClayTools

FIGURE 3-7.  An array of torsos in successive stages of detail.

Here, the detailing process is presented with two torsos in successive stages of detail. The 
voxel density is amazing; capturing the most minute details.
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FIGURE 3-8. The same torsos shown from the back view.
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ClayTools can be exercised in a variety of ways to produce musculature, skin details, 
veins, teeth, horns, etc.

Detailing Tips and Tricks:
Coarse to Fine: Details should be added in a progressively coarse to fine 
nature. Stage the process to define primary details first, like musculature. 
Work in as much of that gross form as possible before stepping up to a higher 
resolution. Change the clay coarseness in custom increments for defining 
smaller features. Skin details can be embossed into the clay at a very fine clay 
resolution.

Working with pieces: It is recommended to utilize multiple pieces when 
detailing this model in order to improve performance and interactivity at high 
resolution. Splitting a model up can be achieved quite easily by defining a clay 
selection and then cut / paste to new piece. Alternatively, the “Separate with 
Curve” feature can be used to split the model into parts based on curves 
drawn around the arms and legs. 

It is best practice to introduce a small amount of overlap between pieces when 
separating them so that they can be recombined later without producing a vis-
ible seam. This can be accomplished by copying a selection to a new piece 
and then deleting a slightly smaller selection from the original piece. 

Pieces can be managed through the ObjectList from the View menu. Once a 
piece is detailed, it can readily be recombined with other pieces by clicking on 
the piece in the ObjectList and choosing “Combine Into”. 

Mirror: Since this model will be symmetrical, it is recommended to only detail 
one arm and one leg. The detailed demon can be mirrored at the end using 
the Mirror command to produce a symmetrical result.
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FIGURE 3-9. The model has been detailed up beautifully, realistically, and the results are 
extremely tactile, to say the least.
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Part 3: Refine the Model and Assign UV Maps in Maya

As you can see in the final detailed model, some new structural features were added which 
did not exist in the original low-resolution mesh model, such as the horns, teeth, tongue, 
and some other protrusions. In order to get the most convincing normal mapped result, we 
will need to ensure that the low-resolution mesh closely approximates the most visible 
silhouette features.

For the purpose of refining the low-resolution mesh, we will export a downsampled 
version of the final demon model. Since we are working with virtual clay, it's fast to 
choose a different resolution for the volume and generate a coarse approximation which 
can be used as a 3D reference inside Maya.

As a first step, take note of the current number of triangles in the model if you were to 
export it. Go to File > Export > Model.

FIGURE 3-10. Location of triangle polygon count information.

Note that the total number of triangles is in excess of 10 million! This is too large and 
densely detailed to serve as a usable reference for refining the low-resolution mesh. It is 
preferable to instead export a medium resolution reference, which represents the most 
important silhouette features.

There are several ways to reduce the ClayTools model to process a more efficient 
reference.
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Change Clay 
Coarseness

The first option to try is to change the clay coarseness. Try reducing the model resolution 
in steps and ensure that the model integrity is maintained. Typically, reducing the clay 
coarseness to “add detail” coarseness will be sufficient and result in a model within the 
range that Maya can handle. 

FIGURE 3-11. The model shown at various clay coarseness settings.

Mesh Optimization via 
Reduce for Export

If further reduction is desired, the “Reduce For Export” feature can be used to perform an 
automatic mesh optimization and reach a target triangle count. 

Import the reference model into the Maya scene containing original low-resolution demon 
mesh. The reference model should appear coincident with the original demon mesh. 

Backup Your File Before Reducing Clay coarseness
Because of the inherent risk of losing detail when reducing clay coarse-
ness, it is advisable to make a backup copy of your original, high-res, 
model before proceeding with reducing clay coarseness.
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It is recommended to set a different shader for the 3D reference model to make it either 
see-through or a different color. This will allow you to more readily see the low-resolution 
mesh vertices and edges that are occluded by the reference model.

FIGURE 3-12. Low-res reference model aligned with Maya model for addition of new features to Maya model. In 
this case the horns had been added in ClayTools and the Maya model needs to be modified to capture these new 

additions.

Use your method of choice for modeling in any additional feature. Remember, it's only 
important to capture the silhouette features from the 3D reference model. Concave 
features that don't contribute to the silhouette can be safely ignored, since the normal map 
will adequately represent them.

The HapticExtender plug-in can also be invaluable in this process for moving vertices 
onto the surface of the reference model. For instance, you can quickly grab vertices for the 
teeth and feel the model from the inside as you move each vertex to the tip of the tooth. 
Additionally, 3d manipulation of vertices with Soft Modification Tool can be used for 
reshaping the mesh in places where muscular was added.
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Below the final tuned demon model, which is ready now for UV mapping. 

FIGURE 3-13. Modified Maya model.

Use your technique of choice for assigning UVs to the low-Resolution demon model.

This particular model is not using mirrored UVs. Please note that mirrored or flipped UVs 
may not be universally supported by all normal map display methods. 

Be sure to check for inverted faces in the UV map before baking a tangent space normal 
map. A tangent space normal map is very sensitive to UV orientation. 
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Part 4: Baking ClayTools Detail into Texture Maps Using TextureKiln

Triangulate the model and export it as obj format. The exported triangle file is best for 
normal map UV reference in the TextureKiln utility. Upon export, undo the triangulation 
as it is no longer needed in Maya. 

FIGURE 3-14. Polygons should be triangulated before export to provide a better reference object for ClayTools 
TextureKiln.
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.

FIGURE 3-15. Triangulated model temporarily imported as a reference piece to check scale of object relative to clay 
piece.

As a sanity check or troubleshooting step, you can import the low-resolution OBJ model 
into ClayTools as a reference piece by checking “Import as reference” from the Import 
dynabar.
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FIGURE 3-16. Reference piece collocated nicely with clay, indicating good alignment of source clay and reference 
geometry for TextureKiln.

If the imported reference piece is collocated with the clay piece, then things are in good 
shape for texture baking.
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FIGURE 3-17. Use Export > TextureKiln on final detailed clay model for baking.
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To bake a normal map from the detailed demon model, select File > Export > TextureKiln 
to invoke the TextureKiln options dialog. 

FIGURE 3-18.  Settings for TextureKiln to create a Normal Map.

Check “Normal Map” from the Map Types. There are additional options available for 
configuring the normal map. In particular, the tangent space normal map has a few 
settings which are specific to the target shader to be used for displaying the normal 
mapped result. There is a preset option in the tangent space settings drop-down called 
“Maya Hardware” which is appropriate for normal map display in Maya.
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In addition to the normal map, you can optionally bake an occlusion map to represent 
ambient shadowing patterns from the clay. An occlusion map is a great way to dirty up a 
diffuse texture. Please note, an occlusion map is more compute intensive than any of the 
other map types. It is recommended to experiment with the normal map first and ensure 
that you are getting the desired results from it before baking an occlusion map.

FIGURE 3-19. Soften all normals of target geometry for mapping as the actual normals will come from the normal 
map created in ClayTools with TextureKiln.
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Part 5: Evaluating the Normal Mapped Result in Maya

Before applying the normal map, make sure that all of the normals are smoothed together.

FIGURE 3-20. Connection editor showing normal map file connection to shader.
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Connecting the file texture normal map to the normal camera channel of the shader 
produces nice clean results for displaying a normal mapped model in the viewport. 
Configure the shader as depicted in the figure above. Note that you will need to at least 
choose a white color for best contrast. Also, you can choose to apply an occlusion map 
baked from ClayTools or a custom painted diffuse texture to the diffuse channel.

FIGURE 3-21. Final low-poly demon model with normal map applied with the Lambert shader
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4

ClayTools to Maya

Chapter 4 Creating A Character Model with 
ClayTools and Maya

This workflow goes through the process of working from ClayTools to Maya to create a 
character model. This is a workflow example with two possible downstream outcomes, 
games or film/video, depending on the decision branch taken at a specific point in the 
middle of the workflow. This workflow assumes the user is already familiar with Maya.

In this particular workflow, the model is created in ClayTools first, and then an optimized 
model and relevant normal or height mapping is derived from that using TextureKiln for 
use in downstream production.

This workflow is broken into the following parts:

Topic Page

Part 1: Creating a Curve Network in ClayTools 4-2

Part 2: Surfacing the Curve Frame in Maya 4-8

Part 3A: Creating Normal Maps in ClayTools 4-15

Part 3B: Creating Height Maps in ClayTools 4-20
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Part 1: Creating a Curve Network in ClayTools

In order to save time, two different people worked in parallel on this example. Modeler 
One developed the overall form of the character as seen in Figure 4-22, and before 
beginning the final detail, handed off a copy of the model to Modeler Two for the 
simultaneous development of the optimized model form. This workflow example begins 
at the handoff. Note that you could also finish the detail first, make a copy of the model 

World units must be consistent

Both Maya and ClayTools should be set to consistent world units in order to 
avoid unnecessary rescaling of units. In ClayTools, this option is found under 
Options. In Maya, this setting is found under the main toolbar heading 
Windows > Settings/Preferences > Preferences > Settings. In this particular 
workflow it is preferable to use centimeters, as this is the native unit of 
measure in Maya. Not adhering to this may cause data to be scaled incorrectly 
due to unit conversion methods used by the OBJ import/export in Maya.
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and apply smoothing (the mapping will pick up the detail on the original), then frame that 
simplified model. If time allows this method is preferred as it creates a better match 
between the final detailed model and the curve frame when mapping is generated.

FIGURE 4-22. The overall form of the minotaur created in ClayTools in four separate pieces: torso, horns, nails and 
teeth. 
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While Modeler One continued on with the final detailing, Modeler Two began to lay out 
curves on the model to capture the basic form of the character with NURBS curves. Using 
the “Slice” tool (Figure 4-23), a center line curve was placed down the mirror line of the 
torso/head clay piece. The other pieces (horns, nails, teeth) were hidden using the Object 
List (shortcut Key O), until we are ready to frame out each with curves.

FIGURE 4-23. Horns, teeth, and nails are hidden using the Object List. The Slice tool is use to create a center line 
curve on the model.

Key features were framed out with edge loops of curves that were fit to clay, using the “Fit 
to Clay” option on the Dynabar, so these animate-able areas of the model topology could 
be determined easily. Since the model can be touched, sensing the actual features and 
outlining them with curves is extremely fast. Note that because you can feel the detail, you 
can trace curves along valleys in the model surface as well as pop inside the model to trace 
along edges of muscle or features such as the rims of the head where the horns join it. The 
model is then covered with four-sided curve boundaries using the curve tool with the 

Slice
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options “Split on Create” set on the dynabar (Figure 4-24), which will become patches in 
Maya. Four-sided is preferred over three. Though three may work in some downstream 
pipelines, they should be avoided.

FIGURE 4-24. Curves drawn fit to clay to capture the form of the character 

In Figure 4-25, half of the model is completely framed out with four sided boundaries. 
Because these curves will be mirrored in Maya, only half of each piece needs to be done. 

Tip  At any point in the process, curves can be edited with the Select tool and 
refit to the surface of the model using the “Fit to Clay” tool. Take time to review 
the model and make sure the framework consists of only four sided boundaries 

Fit on CreateSplit on Create
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(some three-sided are acceptable, but not preferable). Note that because you can 
see and feel the model (haptics), it is much easier to lay out a well defined and 
elegant topology.

FIGURE 4-25. A curve network completely frames out one half of the torso and head.
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The other pieces (horns, nails, and teeth) are completed in the same way by making each 
piece active (and therefore touchable) and tracing the form. In this way, curves are created 
in relation to each piece, and can be exported as a separate IGES file, using File > Export 
> Curves by using the Object List and the Show Only context to show one piece and its 
curves at a time 

FIGURE 4-26. The curve network for each piece of the model has been created and is made visible using the object 
list 
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Part 2: Surfacing the Curve Frame in Maya

Making sure that a common unit of measure is used between ClayTools and Maya (in this 
case centimeters), each part of the model is imported into Maya as IGES curves. Examine 
the curve frame and observe closely to see that all curves form a 4-sided boundary. This is 
necessary for using the Boundary Surface tool in Maya.

FIGURE 4-27. Curve network of torso and head only is imported into Maya. 
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Use the Boundary Surface tool to cover the model frame with surfaces. Set the option to 
Common End Points > Required; it will help in building surfaces in the proper 
boundaries. 

FIGURE 4-28. Boundary Surface tool used in Maya.
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Once the surfaces are completed, use the Edit NURBS > Rebuild Surfaces tool to rebuild 
the surfaces to uniform parameterization. This will allow the proper conversion to a 
uniform polygon mesh.

FIGURE 4-29. Uniform parameterization is achieved by rebuilding the surfaces.
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Once the surfaces are uniform, use Modify > Convert Surfaces to Polygons, with the 
Attach Multiple Mesh option selected. The Merge Tolerance may need some 
experimentation for best results depending on the model. 

FIGURE 4-30. Surfaces are converted to polygons

Use the parameters to control the density of the mesh as needed for the intended 
downstream application. Games will have a fairly light mesh, while film and video may 
be slightly more dense and may be converted later to subD surfaces for rendering.
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Repeat the process for each of the pieces until all pieces are a separate polygon mesh. 
Evaluate the shading of each, making sure all polygon normals are all pointing out in the 
same direction. Good normals are critical in proper map generation.

FIGURE 4-31. Each of the pieces is imported into Maya and surfaced individually

For each piece, use the Maya tools for creating proper UV mapping. In Figure 4-32 the 
teeth are shown in the UV Texture Editor. Backup your file at this time and then 
temporarily make a copy of each piece, triangulate it and export each copy as an OBJ file 
on completion of the UV mapping. Each of the OBJ files will be used to provide the UV 
mapping to the ClayTools TextureKiln function for the creation of the Normal, Occlusion 
or Height maps, depending on the intended downstream pipeline. You may delete the 
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triangulated copies from Maya after export as they will just be used in ClayTools for UV 
reference. In the next section we will create Normal Maps. If you are interested in Height 
Maps jump to “Part 3B: Creating Height Maps in ClayTools” on page 4-20.

FIGURE 4-32. UV Mapping of the teeth.
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FIGURE 4-33. Triangulated copy of the model used for export to ClayTools for baking
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Part 3A: Creating Normal Maps in ClayTools

Once the UV mapping and triangulation is completed on each piece, it is time to capture 
the detail from the highly-detailed finished pieces in ClayTools. Here we see the model at 
a finished level of detail that was complete by Modeler One.

FIGURE 4-34. Front view of detailed model in ClayTools
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FIGURE 4-35. 3/4 view of detailed model in ClayTools.
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Using File > Export > TextureKiln, create either Normal, Occlusion or Height mapping. 
In this example below, a Normal map (An example for creating height maps begins on 
page 4-20) for Maya Hardware at a resolution of 1024 is being created for each piece 
individually by referring to the active piece. After setting the options as below, and 
choosing OK, the reference UV OBJ file is requested and the map is generated.

FIGURE 4-36. TextureKiln is used to create a normal map.
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Applying Normal Maps
Once the Normal map is generated for each piece, a shader for each piece is created in 
Maya and the Normal map file texture is connected to the Normal Camera input using the 
connection editor (middle mouse drag the file texture over the shader, choose Other from 
the pop up, then connect the Out Color of the file to the Normal Camera of the shader.

FIGURE 4-37. Shader is created and connected in Maya.
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For displaying the normal map, make sure the viewing panel uses Shading > High Quality 
Shading, Smooth Shade All, and Hardware Texturing. Below is the normal map example 
test of each piece.

FIGURE 4-38. Complete model shown with Normal Maps in Maya.
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Part 3B: Creating Height Maps in ClayTools

Next follows an example of displacement mapping using the same model and Boundary 
surfaces generated in Maya.

Building for a height map is much the same as for normal mapping; beginning with a 
similar polymesh as before with proper normals and UV mapping.

FIGURE 4-39. Polymesh of model
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Back up your Maya file and make a temporary copy of each piece and triangulate and 
smooth it so no faceting is visible on the surface of the shaded object. Export these as OBJ 
files, which will be used to provide UV reference to ClayTools during the Height map 
generation, and can be deleted from Maya after exporting them.

FIGURE 4-40. Each piece is smoothed to removed faceting on the surface
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Use TextureKiln in ClayTools to generate the height map for each detailed piece of the 
highly-detailed model created by Modeler One (see Figure 4-34), referring to the OBJ 
files with the UV coordinates saved from Maya. Here the height map is being saved at 
2048 pixels for the active piece. The Standard method (as opposed to Statistical) is being 
used. Depending on how closely the UV model OBJ file follows the contour of the clay 
piece will dictate which method to use. 
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In this case, Standard achieved the most usable results, though Photoshop® was used to 
adjust the levels to a more contrasted range. Because the curve frame was created on a 
simple model, which was fairly different in contour than the detailed clay final model, 
some range of the height values was lost. 

FIGURE 4-41. Due to the differences in the two models the height map generated lacks 
some contrast.

FIGURE 4-42. Photoshop is used to adjust the levels.
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Adjusting the file in Photoshop brought the levels back to a wider range. Creating the 
curve frame on the model when it was closer to finish would have made this adjustment 
unnecessary.
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Applying Height Maps
Before the maps are applied, the polygons are converted to SubD surfaces for the Maya 
renderer. The polygons could also be rendered in Maya, mental ray® or RenderMan®.
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Once the file maps have been created, connect the file textures to the shaders on each 
piece. Below, the mapping has been connected to the displacement as well as bump 
channels, and the Alpha Gain and Alpha Offset have been used to adjust the displacement 
map.
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FIGURE 4-43. Test rendering the SubD surfaces in the Maya renderer provided these 
results on a first test.
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FIGURE 4-44. Comparing the basic form of the torso/head on the left to the rendering of the low-poly model with 
texture map applied on the right.
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FIGURE 4-45. Rendered in Maya with all pieces included and some simple lighting and shadows
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